AGS's error trying to open the editor

Started by javixblack, 09 May 2021, 23:50

« previous - next »

javixblack

Hi everyone! I download the AGS 3.5.0.31 P9 version a few days ago, and installed it. When I try to launch the editor, I get the next message (sorry for not put a preview, I don't know why this url doesn't show it):

https://ibb.co/VTRxmnN

The spanish text says "Cannot load the file or assembly 'AGS.Native.dll' or one of its dependencies. Cannot find the specified module"

I can't use the editor when I press "Aceptar", and I haven't any idea of what all of that means.

I am using Windows 7 32 bits, 4gb ram, an intel i3, and that is all I know about computing.

Crimson Wizard

#1
What was the last version of AGS you were using before this one?

Did you download installer or zip archive? Have you installed it in a new folder or over an existing AGS installation? Do you actually have AGS.Native.dll in the editor's folder?


javixblack

#2
QuoteWhat was the last version of AGS you were using before this one?

I don't know, 'cuase I was installed AGS in this particular PC but I never used (it's a notebook, my main PC is a desktop one). I could say was one of the 3.5 versions, but Idk which patch.


QuoteDid you download installer or zip archive?

The installer.


QuoteHave you installed it in a new folder or over an existing AGS installation?

I had the same doubt (sorry, I am a bit silly), so I uninstalled the editor, deleted the folder, and installed in a new one again. And then I wrote to you.


QuoteDo you actually have AGS.Native.dll in the editor's folder?

Yes, there is that file in the editor's folder.

Crimson Wizard

#3
So, you were installing on a system where you did not use AGS before?

Perhaps double check that you have necessary requirements, specifically VC redistributable which is needed for AGS.Native.dll:
https://www.adventuregamestudio.co.uk/site/ags/

Hm, actually, if you used installer it should detect that VC redist is necessary and suggest installing it too...

morganw

If you've just downloaded and extracted the zip file version then likely Windows has flagged everything in the zip file as coming from the Internet, and default .NET restrictions will stop the dll files from being used.

You need to "unblock" the files:
https://adventuregamestudio.github.io/ags-manual/TroubleshootingWindowsZoneID.html#how-do-i-clean-my-ags-editor-files-of-alternate-data-streams

It is much easier to "unblock" the zip file and then extract it, as it is Window's built-in unzipping process that propagates the flag to block the usage.
This problem doesn't affect the installer based version.

javixblack

Quote from: Crimson Wizard on 10 May 2021, 01:16
Perhaps double check that you have necessary requirements, specifically VC redistributable which is needed for AGS.Native.dll:
https://www.adventuregamestudio.co.uk/site/ags/

Oh, I just download de VC redistributable and launched it. That seems to be already installed, so I press in "fix" button. The problem has been solved so far!
I will be testing it and if will be any problem, I'll let you know.

Thanks so much, Wizard!

Quote from: morganw on 10 May 2021, 10:53
If you've just downloaded and extracted the zip file version then likely Windows has flagged everything in the zip file as coming from the Internet, and default .NET restrictions will stop the dll files from being used.

Hi! Crimson Wizard has already help me with the problem. Thanks for your help too (P.S. I was usign de installer instead the .ZIP file)

SMF spam blocked by CleanTalk